Hacker0x01 - react-datepicker 4.2.1 devDependencies status

A simple and reusable datepicker component for React

  • 71 Dependencies total
  • 63 Up to date
  • 1 Pinned, out of date
  • 7 Out of date
DependencyChangesRequiredStableLatestStatus
@babel/core^7.5.57.15.57.15.5
@babel/helpers^7.5.57.15.47.15.4
@babel/plugin-external-helpers^7.2.07.14.57.14.5
@babel/plugin-proposal-class-properties^7.5.57.14.57.14.5
@babel/preset-env^7.5.57.15.67.15.6
@babel/preset-flow^7.0.07.14.57.14.5
@babel/preset-react^7.0.07.14.57.14.5
@wojtekmaj/enzyme-adapter-react-17^0.6.10.6.30.6.3
babel-eslint^10.0.310.1.011.0.0-beta.2
babel-loader^8.0.68.2.28.2.2
babel-plugin-external-helpers^6.22.06.22.07.0.0-beta.3
babel-plugin-react-transform^3.0.03.0.03.0.0
babel-plugin-transform-react-remove-prop-types^0.4.240.4.240.4.24
babel-preset-airbnb^5.0.05.0.05.0.0
chai^4.2.04.3.44.3.4
codecov^3.5.03.8.34.0.0-0
core-js^3.2.13.18.03.18.0
cross-env^7.0.27.0.37.0.3
css-loader
^5.0.06.3.06.3.0
enzyme^3.10.03.11.03.11.0
eslint^7.4.07.32.08.0.0-beta.2
eslint-plugin-import^2.18.22.24.22.24.2
eslint-plugin-node^11.1.011.1.011.1.0
eslint-plugin-promise^5.1.05.1.05.1.0
eslint-plugin-react^7.14.37.26.07.26.0
express^4.17.14.17.15.0.0-alpha.8
flow-bin
^0.132.00.160.10.160.1
highlight.js^11.0.111.2.011.2.0
husky
67.0.27.0.2
istanbul-instrumenter-loader^3.0.13.0.13.0.1
karma^6.0.16.3.46.3.4
karma-chai^0.1.00.1.00.1.0
karma-coverage^2.0.12.0.32.0.3
karma-firefox-launcher^2.0.02.1.12.1.1
karma-mocha^2.0.12.0.12.0.1
karma-mocha-reporter^2.2.52.2.52.2.5
karma-sinon^1.0.51.0.51.0.5
karma-sourcemap-loader^0.3.70.3.80.3.8
karma-webpack
^4.0.25.0.05.0.0
lint-staged^11.0.011.1.211.1.2
mocha^9.0.19.1.19.1.1
npm-run-all^4.1.54.1.54.1.5
prettier^2.0.52.4.12.4.1
react^17.0.217.0.218.0.0-alpha-fd5e01c2e-20210913
react-docgen^5.3.05.4.06.0.0-alpha.0
react-dom^17.0.217.0.218.0.0-alpha-fd5e01c2e-20210913
react-test-renderer^17.0.217.0.218.0.0-alpha-fd5e01c2e-20210913
react-transform-hmr^1.0.41.0.41.0.4
rollup^2.32.02.57.02.57.0
rollup-plugin-babel^4.3.34.4.05.0.0-alpha.2
rollup-plugin-commonjs^10.0.210.1.010.1.0
rollup-plugin-filesize^9.0.29.1.19.1.1
rollup-plugin-local-resolve^1.0.71.0.71.0.7
rollup-plugin-node-resolve^5.2.05.2.05.2.0
rollup-plugin-peer-deps-external^2.2.02.2.42.2.4
rollup-plugin-replace^2.2.02.2.02.2.0
rollup-plugin-terser^7.0.27.0.27.0.2
rollup-plugin-uglify^6.0.46.0.46.0.4
sass
1.37.51.42.11.42.1
sass-loader^12.0.012.1.012.1.0
sinon^11.1.111.1.211.1.2
slugify^1.3.41.6.01.6.0
style-loader
^2.0.03.3.03.3.0
stylelint^13.13.113.13.113.13.1
stylelint-config-standard^22.0.022.0.022.0.0
stylelint-scss^3.19.03.21.03.21.0
webpack
^4.39.25.53.05.53.0
webpack-cli^4.7.04.8.04.8.0
webpack-dev-middleware^5.0.05.1.05.1.0
webpack-dev-server
^3.8.04.2.14.2.1
webpack-hot-middleware^2.25.02.25.12.25.1
  • 71 Dependencies total
  • 63 Up to date
  • 1 Pinned, out of date
  • 7 Out of date