mui-org - 4.10.1 devDependencies status

  • 106 Dependencies total
  • 98 Up to date
  • 1 Pinned, out of date
  • 7 Out of date
DependencyChangesRequiredStableLatestStatus
@babel/cli
    ^7.8.47.10.17.10.1
    @babel/core
      ^7.9.67.10.27.10.2
      @babel/node
        ^7.8.77.10.17.10.1
        @babel/plugin-proposal-class-properties
          ^7.8.37.10.17.10.1
          @babel/plugin-proposal-object-rest-spread
            ^7.9.67.10.17.10.1
            @babel/plugin-transform-object-assign
              ^7.8.37.10.17.10.1
              @babel/plugin-transform-react-constant-elements
                ^7.9.07.10.17.10.1
                @babel/plugin-transform-runtime
                  ^7.9.67.10.17.10.1
                  @babel/preset-env
                    ^7.9.67.10.27.10.2
                    @babel/preset-react
                      ^7.9.47.10.17.10.1
                      @babel/register
                        ^7.9.07.10.17.10.1
                        @rollup/plugin-replace
                          ^2.3.12.3.22.3.2
                          @testing-library/dom
                            ^7.0.37.9.07.9.0
                            @testing-library/react
                              ^10.0.110.0.610.0.6
                              @testing-library/react-hooks
                                3.2.13.2.13.2.1
                                @types/chai
                                  ^4.2.34.2.114.2.11
                                  @types/chai-dom
                                    ^0.0.90.0.90.0.9
                                    @types/enzyme
                                      ^3.10.33.10.53.10.5
                                      @types/fs-extra
                                        ^9.0.09.0.14.0.11
                                        @types/glob
                                          ^7.1.17.1.17.1.1
                                          @types/jsdom
                                            ^16.1.016.2.316.2.3
                                            @types/lodash
                                              ^4.14.1384.14.1554.14.155
                                              @types/mocha
                                                ^7.0.17.0.27.0.2
                                                @types/prettier
                                                  ^2.0.02.0.12.0.1
                                                  @types/react
                                                    ^16.9.316.9.3516.9.35
                                                    @types/sinon
                                                      ^9.0.09.0.49.0.4
                                                      argos-cli
                                                        ^0.1.20.1.30.1.3
                                                        babel-core
                                                          ^7.0.0-bridge.06.26.37.0.0-bridge.0
                                                          babel-eslint
                                                            ^10.0.310.1.011.0.0-beta.2
                                                            babel-loader
                                                              ^8.0.08.1.08.1.0
                                                              babel-plugin-istanbul
                                                                ^6.0.06.0.06.0.0
                                                                babel-plugin-module-resolver
                                                                  ^4.0.04.0.04.0.0
                                                                  babel-plugin-optimize-clsx
                                                                    ^2.3.02.6.02.6.0
                                                                    babel-plugin-react-remove-properties
                                                                      ^0.3.00.3.00.3.0
                                                                      babel-plugin-tester
                                                                        ^9.0.09.2.09.2.0
                                                                        babel-plugin-transform-dev-warning
                                                                          ^0.1.00.1.10.1.1
                                                                          babel-plugin-transform-react-remove-prop-types
                                                                            ^0.4.210.4.240.4.24
                                                                            chai
                                                                              ^4.1.24.2.04.2.0
                                                                              chai-dom
                                                                                ^1.8.11.8.21.8.2
                                                                                chalk
                                                                                  ^4.0.04.0.04.0.0
                                                                                  compression-webpack-plugin
                                                                                    ^4.0.04.0.04.0.0
                                                                                    confusing-browser-globals
                                                                                      ^1.0.91.0.91.1.0-next.103
                                                                                      core-js
                                                                                        ^2.6.113.6.53.6.5
                                                                                        cross-env
                                                                                          ^7.0.07.0.27.0.2
                                                                                          danger
                                                                                            ^10.0.010.2.010.2.0
                                                                                            dom-accessibility-api
                                                                                              ^0.4.30.4.40.4.4
                                                                                              dtslint
                                                                                                ^3.2.03.6.103.6.10
                                                                                                enzyme
                                                                                                  ^3.9.03.11.03.11.0
                                                                                                  enzyme-adapter-react-16
                                                                                                    ^1.14.01.15.21.15.2
                                                                                                    eslint
                                                                                                      ^6.8.07.1.07.1.0
                                                                                                      eslint-config-airbnb
                                                                                                        ^18.1.018.1.018.1.0
                                                                                                        eslint-config-prettier
                                                                                                          ^6.2.06.11.06.11.0
                                                                                                          eslint-import-resolver-webpack
                                                                                                            ^0.12.00.12.10.12.1
                                                                                                            eslint-plugin-babel
                                                                                                              ^5.3.05.3.05.3.0
                                                                                                              eslint-plugin-import
                                                                                                                ^2.18.22.20.22.20.2
                                                                                                                eslint-plugin-jsx-a11y
                                                                                                                  ^6.2.36.2.36.2.3
                                                                                                                  eslint-plugin-mocha
                                                                                                                    ^6.1.17.0.17.0.1
                                                                                                                    eslint-plugin-react
                                                                                                                      ^7.14.37.20.07.20.0
                                                                                                                      eslint-plugin-react-hooks
                                                                                                                        ^2.1.14.0.44.0.4
                                                                                                                        expect-puppeteer
                                                                                                                          ^4.3.04.4.04.4.0
                                                                                                                          format-util
                                                                                                                            ^1.0.51.0.51.0.5
                                                                                                                            fs-extra
                                                                                                                              ^9.0.09.0.09.0.0
                                                                                                                              glob
                                                                                                                                ^7.1.27.1.67.1.6
                                                                                                                                glob-gitignore
                                                                                                                                  ^1.0.111.0.141.0.14
                                                                                                                                  jsdom
                                                                                                                                    ^16.0.016.2.216.2.2
                                                                                                                                    karma
                                                                                                                                      ^5.0.15.0.95.0.9
                                                                                                                                      karma-browserstack-launcher
                                                                                                                                        ~1.4.01.6.01.6.0
                                                                                                                                        karma-chrome-launcher
                                                                                                                                          ^3.0.03.1.03.1.0
                                                                                                                                          karma-mocha
                                                                                                                                            ^2.0.02.0.12.0.1
                                                                                                                                            karma-mocha-reporter
                                                                                                                                              ^2.2.52.2.52.2.5
                                                                                                                                              karma-sourcemap-loader
                                                                                                                                                ^0.3.70.3.70.3.7
                                                                                                                                                karma-webpack
                                                                                                                                                  ^4.0.24.0.25.0.0-alpha.3.0
                                                                                                                                                  lerna
                                                                                                                                                    ^3.16.43.22.03.22.0
                                                                                                                                                    lodash
                                                                                                                                                      ^4.17.154.17.154.17.15
                                                                                                                                                      mocha
                                                                                                                                                        ^7.0.07.2.07.2.0
                                                                                                                                                        node-fetch
                                                                                                                                                          ^ 2.6.02.6.03.0.0-beta.6-exportfix
                                                                                                                                                          nyc
                                                                                                                                                            ^15.0.015.1.015.1.0
                                                                                                                                                            prettier
                                                                                                                                                              ^2.0.12.0.52.0.5
                                                                                                                                                              pretty-bytes
                                                                                                                                                                ^5.3.05.3.05.3.0
                                                                                                                                                                pretty-format-v24
                                                                                                                                                                  npm:pretty-format@24
                                                                                                                                                                  prop-types
                                                                                                                                                                    ^15.7.215.7.215.7.2
                                                                                                                                                                    puppeteer
                                                                                                                                                                      ^3.0.03.3.03.3.0
                                                                                                                                                                      react
                                                                                                                                                                        ^16.13.016.13.10.0.0-experimental-33c3af284
                                                                                                                                                                        react-dom
                                                                                                                                                                          ^16.13.016.13.10.0.0-experimental-33c3af284
                                                                                                                                                                          react-test-renderer
                                                                                                                                                                            ^16.13.016.13.10.0.0-experimental-33c3af284
                                                                                                                                                                            remark
                                                                                                                                                                              ^12.0.012.0.012.0.0
                                                                                                                                                                              rimraf
                                                                                                                                                                                ^3.0.03.0.23.0.2
                                                                                                                                                                                rollup
                                                                                                                                                                                  ^2.10.82.12.12.12.1
                                                                                                                                                                                  rollup-plugin-babel
                                                                                                                                                                                    ^4.3.34.4.05.0.0-alpha.2
                                                                                                                                                                                    rollup-plugin-commonjs
                                                                                                                                                                                      ^10.1.010.1.010.1.0
                                                                                                                                                                                      rollup-plugin-node-globals
                                                                                                                                                                                        ^1.4.01.4.01.4.0
                                                                                                                                                                                        rollup-plugin-node-resolve
                                                                                                                                                                                          ^5.2.05.2.05.2.0
                                                                                                                                                                                          rollup-plugin-size-snapshot
                                                                                                                                                                                            ^0.12.00.12.00.12.0
                                                                                                                                                                                            rollup-plugin-terser
                                                                                                                                                                                              ^6.1.06.1.06.1.0
                                                                                                                                                                                              sinon
                                                                                                                                                                                                ^9.0.09.0.29.0.2
                                                                                                                                                                                                size-limit
                                                                                                                                                                                                  ^0.21.04.5.04.5.0
                                                                                                                                                                                                  ts-node
                                                                                                                                                                                                    ^8.3.08.10.28.10.2
                                                                                                                                                                                                    tslint
                                                                                                                                                                                                      5.14.06.1.26.1.2
                                                                                                                                                                                                      typescript
                                                                                                                                                                                                        ^3.8.23.9.34.0.0-dev.20200603
                                                                                                                                                                                                        typescript-to-proptypes
                                                                                                                                                                                                          ^1.5.02.0.12.0.1
                                                                                                                                                                                                          unist-util-visit
                                                                                                                                                                                                            ^2.0.22.0.22.0.2
                                                                                                                                                                                                            vrtest-mui
                                                                                                                                                                                                              ^0.3.30.3.30.3.3
                                                                                                                                                                                                              webpack
                                                                                                                                                                                                                ^4.41.04.43.05.0.0-beta.17
                                                                                                                                                                                                                webpack-cli
                                                                                                                                                                                                                  ^3.3.93.3.114.0.0-beta.8
                                                                                                                                                                                                                  yargs
                                                                                                                                                                                                                    ^15.2.015.3.115.4.0-beta.0
                                                                                                                                                                                                                    yarn-deduplicate
                                                                                                                                                                                                                      ^2.0.02.0.02.0.0
                                                                                                                                                                                                                      • 106 Dependencies total
                                                                                                                                                                                                                      • 98 Up to date
                                                                                                                                                                                                                      • 1 Pinned, out of date
                                                                                                                                                                                                                      • 7 Out of date