rucken - rucken-core-nestjs 1.0.12 dependencies status

A simple application demonstrating the basic usage of permissions with NestJS (JWT, Passport, Facebook, Google+, User, Group, Permission)

  • 42 Dependencies total
  • 14 Up to date
  • 26 Pinned, out of date
  • 2 Out of date
DependencyChangesRequiredStableLatestStatus
@angular-devkit/architect
    0.13.90.901.10.1000.0-next.0
    @angular-devkit/build-angular
      0.13.90.901.10.1000.0-next.0
      @angular-devkit/core
        7.3.99.1.110.0.0-next.0
        @angular-devkit/schematics
          7.3.99.1.110.0.0-next.0
          @nestjs/common
            6.1.17.0.77.0.7
            @nestjs/core
              6.1.17.0.77.0.7
              @nestjs/passport
                6.0.07.0.07.0.0
                @nestjs/platform-express
                  ^6.1.17.0.77.0.7
                  @nestjs/swagger
                    ^3.0.24.5.14.5.1
                    @nestjs/typeorm
                      6.1.07.0.07.0.0
                      @nrwl/nx
                        7.8.57.8.78.0.0-alpha.4
                        @types/passport-facebook-token
                          0.4.330.4.340.4.34
                          @types/passport-local
                            1.0.331.0.331.0.33
                            chmod
                              0.2.10.2.10.2.1
                              class-transformer
                                ^0.2.00.2.30.2.3
                                class-validator
                                  0.9.10.11.10.12.0-refactor.5
                                  connection-string
                                    2.4.03.2.03.2.0
                                    cp-cli
                                      2.0.02.0.02.0.0
                                      cross-env
                                        5.2.07.0.27.0.2
                                        del-cli
                                          1.1.03.0.03.0.0
                                          dotenv
                                            8.0.08.2.08.2.0
                                            fast-glob
                                              2.2.63.2.23.2.2
                                              fastify-formbody
                                                3.1.03.1.02.1.0
                                                highlight.js
                                                  9.15.69.18.110.0.0-beta.0
                                                  jsonwebtoken
                                                    8.5.18.5.18.5.1
                                                    node-django-hashers
                                                      1.1.61.1.61.1.6
                                                      passport
                                                        0.4.00.4.10.4.1
                                                        passport-facebook-token
                                                          3.3.03.3.03.3.0
                                                          passport-google-plus-token
                                                            2.1.02.1.02.1.0
                                                            passport-http-bearer
                                                              1.0.11.0.11.0.1
                                                              passport-jwt
                                                                4.0.04.0.04.0.0
                                                                passport-local
                                                                  1.0.01.0.01.0.0
                                                                  pg
                                                                    7.10.08.0.08.0.0
                                                                    reflect-metadata
                                                                      0.1.130.1.130.1.13
                                                                      rxjs
                                                                        6.5.26.5.57.0.0-beta.0
                                                                        sqlite3
                                                                          4.0.74.1.14.1.1
                                                                          swagger-ui-express
                                                                            ^4.0.24.1.44.1.4
                                                                            ts-node
                                                                              8.1.08.8.28.8.2
                                                                              tsconfig-paths
                                                                                3.8.03.9.03.9.0
                                                                                typedoc
                                                                                  0.14.20.17.40.17.4
                                                                                  typeorm
                                                                                    0.2.170.2.240.3.0-rc.19
                                                                                    typescript
                                                                                      3.2.23.8.33.9.0-dev.20200408
                                                                                      • 42 Dependencies total
                                                                                      • 14 Up to date
                                                                                      • 26 Pinned, out of date
                                                                                      • 2 Out of date